Minimum Requirements

Before you can develop ownCloud applications, as with developing other software applications, you have to ensure that you have a working development environment.

To do that:

  • First, ensure that your development environment meets the minimum requirements

  • Then, create the core files that any ownCloud application needs

There aren’t many; all that you’ll need is:

  • PHP, with a minimum version of 5.6, though ideally 7.1

  • A copy of ownCloud core

  • A working installation of ownCloud server

To find out more, read through the Development Environment section. When you’ve done everything that it suggests, you’re ready to begin developing an ownCloud application.